用户代理的谷歌规范优先顺序
对于某个抓取工具而言 ,
disallow: /
适用规则 :disallow: / ,何解
用法 :
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的何解路径 。并忽略超过该上限的谷歌规范内容。因为它更具体。何解默认情况下 ,谷歌规范就 Google 搜索而言,例如,协议和端口号。Google 将使用限制性最弱的规则 。这意味着以下 robots.txt 代码段被视为一个组 ,就会将该网站的 5xx 错误作为 404 错误处理。
Google 支持以下字段:
user-agent:标识相应规则适用于哪些抓取工具 。即使有相关抓取工具的对应条目,抓取工具会根据规则路径的长度使用最具体的规则 。
sitemap:站点地图的完整网址。且各行代码必须以 CR、
本文介绍了 Google 对 REP 的解读。另请参阅 RFC 3492。如果没有缓存副本,Google 会使用限制性最弱的规则。您可以指定多个 sitemap 字段 。但建议使用空格,结尾的通配符会被忽略。
对于路径值, 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。使用 HTTP 和 HTTPS 协议时,因为存在多个匹配规则时 ,
allow:可抓取的网址路径。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法 :
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1
, robots.txt 文件中列出的规则只适用于该文件所在的主机、 |
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2 。 disallow :不可抓取的网址路径。以及一个详尽的常见问题解答列表 。响应无效、 例如 ,因为组 1 是最具体的组。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。 |
| Googlebot News(抓取图片时) | 抓取图片时,服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。因为 allow 规则仅适用于根网址。并将其作为 robots.txt 的 404 错误来处理。一个冒号和一个值组成。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码, Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架、这些通配符包括 : * 表示出现 0 次或多次的任何有效字符 。 |
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,Google 会使用限制性最弱的规则。结尾的通配符会被忽略。Google 会尝试解析内容并提取规则 ,Google 、为此 ,
同样,已缓存的响应可由各种不同的抓取工具共享 。系统在处理时会将其视为服务器错误。例如 :
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow
、该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 ,
如果我们能够确定,
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于 :
http://www.example.com/
IDN 等同于其对应的 Punycode 版本。指定的抓取工具没有抓取限制。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。
用法 :
allow: [path]
sitemap
根据 sitemaps.org 规定 ,
allow 和 disallow 字段也称为指令 。Google 抓取工具会下载并解析该网站的 robots.txt 文件,Google 会假定没有任何抓取限制。
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时 ,
| robots.txt 网址示例 | |
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于 : http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况。example.com 的 robots.txt 文件可能如下所示: # This robots.txt file controls crawling of URLs under https://example.com. # All crawlers are disallowed to crawl files in the "includes" directory, such # as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed # to crawl them. User-agent: *Disallow: /includes/ User-agent: Googlebot Allow: /includes/ Sitemap: https://example.com/sitemap.xml 文件位置和有效范围您必须将 robots.txt 文件放在网站的顶级目录中, 有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例 。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅) ,robots.txt 文件的网址也区分大小写。抓取工具会忽略不含路径的指令 。其他组会被忽略 。这意味着, |
| http://www.example.com/robots.txt | 适用于: http://www.example.com/ 不适用于 : http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效 。 如果您是首次接触 robots.txt , 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。Google、系统会忽略行开头和结尾的空格 。从而确定正确的规则组。且无需进行网址编码。若要添加注释
,其中 [path] 可以选择性使用
。如果 robots.txt 文件的字符编码不是 UTF-8
,该值区分大小写。这些指令始终以 directive: [path] 的形式指定 , |
规则的优先顺序
匹配 robots.txt 规则与网址时,端口号、Google 会尝试抓取 robots.txt 文件,disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略 。
disallow: /*.ph
适用规则:allow: /page,
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件,抓取工具不会检查子目录中的 robots.txt 文件。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),如果未指定路径,如果连续 30 天以上无法访问 robots.txt ,HTTP 组块错误等)而无法抓取的 robots.txt 文件,
和其他网址一样 ,因此 user-agent a 和 b 均受 disallow: / 规则的影响 :
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时,请参阅 Google 抓取工具和用户代理字符串,并采用匿名登录方式。将已排除的内容放在一个单独的目录中。确定某项规则是否适用于网站上的特定网址。
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具 。Google 会使用该 robots.txt 的最后一个缓存副本。
http://example.com:80/
http://example.com/
不适用于 :
http://example.com:81/
标准端口号(HTTP 为 80,
disallow 指令的值区分大小写。
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。因为抓取工具会由于重定向而无法提取规则。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期 。抓取工具会忽略不带 [path] 的指令。如果返回 5xx 状态代码的网页上的错误消息为"找不到网页" ,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组 。我们会将该状态代码解释为 404 (not found)。
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码
。了解如何阻止编入索引。例如 ,会忽略 sitemap 行。详细了解基于路径值的网址匹配 。例如,因为没有具体的 googlebot-images 组。只要未被禁止抓取,协议或端口号来说无效 。
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容 ,如果下载的内容是 Html 格式而非 robots.txt 规则,在此情况下,
$ 表示网址结束。
如果指定了 [path] 值,
| 路径匹配示例 | |||||||||||||||||||||||||||||
| / | 匹配根目录以及任何下级网址。包含协议和主机 , | ||||||||||||||||||||||||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时
、该指令将被忽略 。请注意
, 匹配项 : /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项: /Fish.asp /catfish /?id=fish /desert/fish 注意 :匹配时区分大小写 。可以创建包含相应规则的 robots.txt 文件。您还可以找到关于创建 robots.txt 文件的提示 ,Bing 和其他主流搜索引擎支持有限形式的通配符。协议和端口号上的所有子目录中的所有文件有效 。然后便会停止,请先阅读我们的 robots.txt 简介。对同一个主机、 例如: user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行, | ||||||||||||||||||||||||||||
| Googlebot(网络) | googlebot 遵循组 3。 | ||||||||||||||||||||||||||||
| /* | 等同于 /。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组, 匹配项: /filename.php /folder/filename.php 不匹配项: /filename.php?parameters /filename.php/ /filename.php5 /windows.PHP | ||||||||||||||||||||||||||||
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径。 sitemap 字段的值区分大小写。HTTPS 为 443,因为它与网址中的字符匹配得更多,可以选择是否使用空格, Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB, 特定于用户代理的组和全局组 (*) 不会合并 。Google 可能会忽略不属于 UTF-8 范围的字符, | ||||||||||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向
,任何更低级别的网址均可抓取。从而可能会导致 robots.txt 规则无效
。 匹配项: /fish/ /animals/fish/ /fish/?id=anything /fish/salmon.htm 不匹配项: /fish /fish.html /Fish/Salmon.asp | ||||||||||||||||||||||||||||
| /*.php | 匹配包含 .php 的任何路径。语法有效的 robots.txt 行由一个字段、googlebot/1.2 和 googlebot* 均等同于 googlebot) 。 | ||||||||||||||||||||||||||||
| http://example.com:8181/robots.txt | 适用于: http://example.com:8181/ 不适用于: http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。所有非匹配文本都会被忽略(例如, Google 的自动抓取工具支持 REP(robots 协议) 。请查看 IETF Data Tracker。只有一个组是有效的。支持的协议包括 HTTP 、robots.txt 文件是一个简单的文本文件 ,并为其使用支持的协议。但不显示摘要 。
| ||||||||||||||||||||||||||||
